Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Estlcam Steuerung
#1
Hallo
Ich habe ein Problem mit dem Umprogrammieren der Estlcam-Steuerung. Nachdem ich feststellte, dass die X-Achse nicht die programmierten Werte fräste, wollte ich den Wert in der Steuerungssoftware anpassen. Ich trug den neuen Wert ein, drückte auf programmieren und es erfolgte eine entsprechende Reaktion, wie in Estlcam beschrieben. Wenn ich die Achse laut Anzeige 400 mm
fahre  sind es real 404. Ich habe den Wert schon von den nötigen 20,2 auf 23 geändert. Ohne Erfolg.
Ich habe Estlcam schon neu installiert, den Mega getauscht - keine Änderung. Hatte jemand schon einmal ein gleiches Problem gehabt?
Mir fällt nichts mehr ein.
Grüsse Herry
Zitieren
#2
Hallo,
in ESTLCAM haben wir 2 Werte mit denen der Verfahrweg angepasst werden kann.

1. Schritte je Umdrehung
Das ist der Wert den man am Motortreiber eingestellt hat z.B. 400 Schritt/U.

2. Weg je Umdrehung
Welchen Weg legt z.B. die X Achse zurück, wenn die Motorwelle eine Umdrehung gemacht hat.

Bei 1:1 Übersetzten Kugelumlaufspindeln z.B. 1204, wären das in dem Fall 4mm.
Es gibt dann noch z.B. 1605, hier wären das denn 5mm.
Bei Trapezgewinde, mit kleineren Durchmessern haben wir oft eine Steigung von 3mm.

Schwieriger wird es bei Antrieben mit Übersetzung z.B. durch einen Riemen, hier muss man sich je nach Konstruktion die Sache ausrechnen.

Ich schreibe das hier so ausführlich weil mich erstmal der Wert 20,2 oder 23 Stutzig macht.
Hast du einen Antrieb mit Übersetzung ?

Grüße
Ralf
www.arduinoclub.de - Elektronik & Programmierung
www.arduinoclub.shop - CNC Steuerungen usw.
Zitieren
#3
Hallo Ralf
Danke für die Antwort
Der Wert von ca. 20mm ergibt sich aus der Übersetzung des Riemenantriebs. Egal ob ich bei den Einstellungen 20 oder z.B. 23 eintrage
und an den Arduino schicke, die Fräse fährt den gleichen Weg. Ich frage mich, ob das Programm die Werte tatsächlich überträgt oder
nur so tut. Auf jeden Fall ändert sich nichts.
Zitieren
#4
Hallo,
das die Werte übertragen werden, gehe ich aber mal schwer von aus.
Wähle doch mal einen Wert der die Fahrstrecke z.B. halbieren würde, dann weist du bescheid.

Ansonsten muss ich sagen, das ich da einigermaßen ratlos bin.
Hast du das Problem auf allen Achsen ?
Grüße
Ralf
www.arduinoclub.de - Elektronik & Programmierung
www.arduinoclub.shop - CNC Steuerungen usw.
Zitieren
#5
Hallo Ralf
Das Rätsel ist gelöst. Die Elektronik war es nicht, sondern der Idiot der sie bedient hat. Mehr sag ich dazu nicht.
Es ist peinlich.
Grüsse Herry
Zitieren




Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste