Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Neu hier und Problem mit Leadshine-Driveranschluß
#1
Hallo zusammen!
Ich heiße Georg, bin neu hier im Forum, fast 60 Jahre alt und von Haus aus Maschinenbautechniker.
Seit nunmehr 50 Jahren betreibe ich leidenschaftlich Modellbau, überwiegend Flugmodelle (elektrisch).

Zum Arduino bin ich erst im letzten Jahr gestoßen, als ich mir Schaltungen über Blitzlichter an Flugmodellen
nachgebaut habe. Da bin ich also noch absoluter Newbie...

Nun zum Problem:
Ich benutze seit einiger Zeit Estlcam 11 als CAM-Modul beim Betrieb einer kleinen GRBL-Chinafräse mit gutem Erfolg.
Deshalb baue ich mir gerade eine größere "Fräse" vom Typ MPCNC zum fräsen von Schaum und Holz.
Beim Verdrahten des Schaltschrank ergibt sich gerade ein Problem, welches ich auch mit Hilfe von "Tante Google" noch nicht lösen konnte:
Ich verwende das Arduino-Club CNC-Controller-Board Rev.5.1 und 5 Stk. Endstufen vom Typ Leadshine DM320T.
Leider sind die Eingänge dort anders belegt, als in der Aufbaubeschreibung in Estlcam:
Dort (Leadshine DM542 EU) werden 4 Eingänge in die Endstufe benutzt:  PUL+; PUL-; DIR+; DIR-  (ENA+ und ENA- sind nicht angeschlossen).
Das klingt logisch.
Bei den Eingängen der DM320T (übrigens auch bei DM332T und DM422C) gibt es nur: OPTO (für 5V+); PUL und DIR. (zusätzlich auch ENA).
Es gibt also kein Ground! Siehe auch Attachment.

 Huh

Ich habe vom 5.1-Controller DIR, STEP und Vout auf die Eingänge der Endstufe gelegt, aber es funktioniert nicht. Weder gibt es "Rauchzeichen", noch eine Fehler-LED, noch
bewegt sich der Motor. Am Bildschirm verändert sich beim Testen aber die Anzeige der Achsposition.
Auch eine Rückfrage bei Christian von Estlcam konnte mir nicht helfen. Das Anschlußschema war ihm auch nicht geläufig.
Zudem ist er skeptisch, ob das wirklich echte Leadshine Driver sind oder nur Nachbauten.

Ich habe diese bei Stepper-Online als Leadshines im Dezember gekauft. Sehen zumindest so aus und sind auch so beschrieben, aber wer weiß...

Hat jemand eine Idee, welche Anschlußmöglichkeit ich noch habe? Ansonsten war das ein Fehlkauf und ich würde sie sehr günstig an einen Interessenten abgeben.

Grüße
Georg


Angehängte Dateien Thumbnail(s)
   
Zitieren


Nachrichten in diesem Thema
Neu hier und Problem mit Leadshine-Driveranschluß - von jogi-essen - 12.01.2019, 11:38

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste