Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Mega Karte mit den JMC iHSS60-36-30?
#1
Hallo

ich baue gerade an meiner 1-ten CNC Fräse. Eigentlich, weil ich noch jede Menge Teile habe, die ich verbauen wollte. Daher ist das auch ein kleiner Frankenstein und nicht alles sauber abgestimmt, aber das ist so in Ordnung.

Motoren sind bis jetzt 180Ncm 2,5A Nema 23 von Letmathe.
Eigentilch dachte ich, die sind auf jeden Fall gut. Antreiben wollte ich die mit Powelolu Boards, weil ich davon noch einige hier habe aus vorigen Projekten.
Nun hab ich die X und Y Achsen mal zusammen geschraubt und so gut ich konnte ausgerichtet, Motoren dran und wollte schauen, was passiert.
Das Verhalten ist aber etwas merkwürdig:
lasse ich ein Programm laufen, dann bin ich bei etwa 1200mm/min am Limit, dann bleibt eventuell das Portal schon stehen.
Wenn ich über die Pfeile einzelne Achsen in ESTLCAM verfahre, geht es auch deutlich schneller.
An der Z-Achse ist noch gar nichts angeschaubt, nur der Motor, und selbst der bleibt stehen, wenn ich zu schnell fahre. Wobei ich 3000mm/min gar nicht so schnell finde.
Eingestellt habe ich Vollschritte, wobei ich auch schon mit Halbschritten und so weiter experimentiert habe.

Ich bin mir nun nicht sicher, an was es liegt: Endstufe, Motor, Mechanik, Steuerung.
Steuerung ist die Mega Karte, das sollte gehen. Mechanik ist ohne die Motoren recht leicht von Hand zu bewegen.

Also überlege ich jetzt, ob ich mir Endstufe oder Motor neu kaufen soll. Und da gefallen mir diese JMC CL Schrittmotoren. Da hätte ich dann beides, aber sind bei 4 Motoren etwa 560€.
Hat jemand diese Motoren an der Mega Karte und kann etwas dazu sagen?


Ach ja, wenn jemand die Letmathe Motoren hat, und dazu etwas sagen kann, wäre ich da selbstverständlich auch interessiert.

Danke Big Grin
Vielen Dank für jede Hilfe, Anja
Zitieren
#2
Hallo Anja,

das von dir beschriebene Verhalten hat nichts mit den Motoren zu tun.
Hatte die gleichen (180Ncm 2,5A Nema 23 von Letmathe) in meinem CNC14 Klon und da liefen sie einfach nur gut.

Grundsätzlich solltest du im Microschrittbetrieb arbeiten. Dann laufen die Motoren ruhiger und sanfter.

Wenn du über Estlcam schneller fahren kannst als in einem Programm, könnte das an den Einstellungen in Estlcam liegen.
Teste mal eine DXF die nur gerade Fräsbahnen hat. Ein Rechteck z.B. Da werden die Abbrems- und Beschleunigungsoptionen von Estlcam nicht gebraucht.

Ein paar Fragen:
Mit welchen Komponenten werden die Achsen bewegt? KUS, Trapez, Gewindestangen oder Zahnriemen?
Hast du mal den Weg gemessen der gefahren wird wenn du z.B. 200mm in Estlcam eingibst.....
Wie hoch ist der Strom bei den Powerlolu die du den Motoren spendierst?
Mit welcher Spannung werden die versorgt?

Da ich die Powerlolu nicht kenne, weiß ich auch nicht über deren Einstellungen. Habe nur gelesen, dass es hier und da Probleme gibt.
Als Endstufen würde ich dir die nicht empfehlen.

In meiner neue Fräse sind JMC iHSS60-36-30 verbaut.
Die laufen super, haben mehr Leistung und sind CL.
Grundsätzlich laufen die auch auf dem ArduinoClub Mega Bord problemlos.
Die Motoren brauchen ein Enable-Signal. Das muss man dann manuell machen über einen Schalter oder sogar über ein SSR.

Gruß Klaus
Zitieren
#3
Hallo Klaus

das klingt also als wäre es ein Endstufenproblem. Dann müsste ich mir neue besorgen. Welche kannst du denn emfpehlen oder mit welchen hat es bei dir gut funktioniert?

Das mit ESTLCAM hast du falsch verstanden - in der ESTLCAM COntroller gibt es links diese Pfeile mit denen man manuell verfahren kann. Wenn ich in der Steuerung die maximlae Geschwindigkeit auf 10000mm/min stelle, Trägheit auf 90%, Beschleunigungsweg 10mm dann kann ich bis etwa 4000mm/min von Hand verfahren.
Nur wenn ich dann ein Programm ablaufen lasse zum Beispiel mit einem einfachen Kreis oder Rechteck, muss ich deutlich reduzieren.



Ein paar Antworten auf deine Fragen - sind direkt an die Motoren über Klauenkupplungen angetbrachte 1605KUS.
Der Weg hat immer gestimmt, also mit unterschiedlichen Microschritten. Ich bin am Ende auf die Vollschritte weil ich das grösste Drehmoment haben wollte.
Den Strom hab ich auf etwa 2.5A eingestellt so gut es eben an den POWERLOLU geht. Netzteil ist ein 50V.
Vielen Dank für jede Hilfe, Anja
Zitieren
#4
Hallo Anja, 

das mit Estlcam habe ich richtig verstanden. Vll habe ich mich nur falsch ausgedrückt. 
Manuell geht bis 4000mm, im Programm bleiben die Motoren stehen. 

Bei Kurvenfahrt werden beide Achsen gleichzeitig bewegt, bzw. auch mal alle drei auf einmal. Wenn du manuell verfährst, dann nur eine Achse oder auch mehr? 
Daher auch mein Vorschlag mal ein großes Rechteck in der Luft zu fräsen. Eventuell geht das auch mit mehr Geschwindigkeit. Es ist halt ungewönlich, dass manuell die Geschwindigkeit erreicht wird und per Programm nicht. Ich konnte nicht ausfindig machen welche Taktfrequenz deine Treiber ab können. 

Ansonsten gibt es mehrere Ansatzpunkte. Einer wäre die Zeit für die Impulse für die Treiber unter Estlcam in den Steuerungseinstellungen. Die mal höher einstellen (siehe auch Hilfefenster in Estlcam). Wenn nämlich die Zeit zu kurz ist, kann es sein dass die Endstufen nicht alles mitbekommen was die Steuerung sagt. 

Ich hatte erst die Endstufen von Letmathe DM556D. Würde sagen, die sind ok. Bin dann auf original Leadshine DM542EU umgestigen. Die laufen ruhiger, sanfter und die Motoren klingen angenehmer. Von denen habe ich noch 3 St. hier liegen. Waren in meinem CNC14 Klon. Bei Bedarf kannst du die haben und mal testen. 

2,5 Amp ist soweit ok. Die Spannung sollte nicht über 45V= liegen.

Gruß Klaus
Zitieren
#5
Hallo Klaus

die Einstellung in ESTLCAM mit der Dauer des SIgnals werde ich suchen, vielleicht funktioniert das.
Jetzt bin ich mir gar nicht mehr sicher was genau ich alles schon versucht habe. Nächstes mal an der Maschine werde ich ein paar Notizen machen :-)

Die DM542EU habe ich gesehen und überlege gerade, mir diese zu bestellen. Nur bleibt eben die Frage ob sich neue Motoren nicht auch lohnen würde. Und so ein CL System reizt mich schon. Na ja, hab ja noch bisschen zu überlegen.

Vielen Dank auf jeden Fall !
Vielen Dank für jede Hilfe, Anja
Zitieren
#6

24.02.2020, 20:23
   

Wenn du dich für DM542EU entscheidest, kannst du meine haben. 
Wenn also Bedarf besteht, einfach melden per PM

Gruß Klaus
Zitieren
#7
Danke für das Bild, schau ich mir an. Und wegen den DM542EU melde ich mich
Vielen Dank für jede Hilfe, Anja
Zitieren
#8
Noch eine Frage an Klaus
kannst du dich erinnern, welche Geschwindigkeit mit den Letmathe Motoren möglich war? Vielleicht hab ich ja auch total falsche Vorstellungen
Vielen Dank für jede Hilfe, Anja
Zitieren
#9
Hallo Anja,

meine Maschine machte 5000mm/min. mehr habe ich nicht getestet.

Damit hier keine Augenwischerei entsteht:
Die ct' Hacks Fräse oder CNCN14 Klon wird über einen Zahnriemen angetrieben.
In Estlcam sind die Daten hinterlegt. Siehe das Bild in einem vorherigen Beitrag.
Eine Umdrehung des Motors bewegte die Achse um 20mm. Rechnerisch komm man da auf 250 U/min.

Kann daher nicht sagen was die Motoren nach oben hin können. Da wäre sicherlich eine Anfrage an Letmathe vorteilhaft.

Meine neue Fräse, (PFM2.5) hat JMC iHSS60 NEMA24 Motoren. Die drehen aktuell knapp 1000 U/min.
Bei einer KUS mit 5mm Steigung sind das 4800 mm im Eilgang. Mehr will ich gar nicht - so groß ist die Fräse ja auch nicht.

Gruß Klaus
Zitieren
#10
Danke, aber 5000mm/min sind weit weg von dem was ich bisher erreichen konnte. Ich werde heute Abend nochmal testen und mir etwas überlegen.

Vielen lieben Dank für Eure Hilfe
Vielen Dank für jede Hilfe, Anja
Zitieren




Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste