Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
en+ TB6600 Anschluss?
#1
Hallo zusammen!

Ich habe eube AC-CNC2017-2S REV5.1 gebaut. Diese soll das Arduino-Shield ersetzen, weil mir da ständig die Kühler abfallen und dann abrauchen.

Als Treiber habe ich heute 4 TB6600 und ein SSR-40 DA erhalten.
Einen Treiber habe ich schonmal "trocken" verkabelt und mir fällt auf, dass ich einen EN+ noch anschließen könnte, weiss aber nicht wo. Confused 
Braucht man das? Auf dem AnschlussDiagramm ist davon nichts erwähnt...

Die mit "-" gekennzeichten Anschlüsse habe ich gebrückt und ein Kabel würde an der Platine auch auf Ground gehen.
Die beiden "DIR+" und "STEP+" werden natürlich auf die jeweiligen Plätze an X, Y, oder Z gesteckt.

Da ich nun 2 Y-Motoren habe, würde ich die Anschlüsse so wählen, dass jeder Motor einen Treiber hat, DIR und STEP würde ich zusammenfassen und an Y auf dem Board anschließen.

Die Motor-Anschlüsse muss ich anhand der mitgelieferten Kabel verifizieren, weil ich 4adrige LED-Kabel als Verlängerung verwenden werde.

Zum Test habe ich das SSR mal an den Spindel-Ausgang geschaltet. In ESTLCAM habe ich ein Mini-Projekt gefräst und das SSR schaltet die interne LED ein und aus... Das wird also funktionieren.
Da die Endschalter und der Spindelschalter funktionieren, erwarte ich bei den Motoren keine Überraschungen mehr. Die Platine und die Motortreiber erhalten jeweils separate Spannungsversorgung.

Ich hoffe, dass das bis hierhin schon korrekt aufgebaut ist.

Viele Grüße aus Dienheim

Rainer
Zitieren
#2
Hallo,
ESTLCAM unterstützt Enable nicht, deshalb hat die Karte keinen Anschluss dafür.
Enable ist eine Art Stromsparmodus, der aber den Nachteil hat das die Motoren Ihren Haltestrom verlieren, das will eigentlich niemand, da man nach dem Einschalten den Koordinaten nicht mehr trauen könnte.

Du kannst ja mal in das Motor PDF schauen, da findest du bestimmt noch Anregungen.
https://www.arduinoclub.shop/WebRoot/Sto...rMotor.pdf

Grüße
Ralf
www.arduinoclub.de - Elektronik & Programmierung
www.arduinoclub.shop - CNC Steuerungen usw.
Zitieren
#3
Danke!

Mein Denkfehler lag in den verwirrenden Videos beim Anschluss an einen Arduino. Ich habe nun alles verdrahtet, wie es in der PDF im Anschlussdiagramm gezeichnet war. Jeder Motor hat seinen eigenen Treiber. 2x Y-Achse, parallel geschaltet. Die Tage kommt ein 30A Netzteil, wo ich dann drei 12V-Anschlüsse für die Treiber habe.

Ich freue mich schon, wenn die Fräse die ersten Bahnen zieht.

Vielen Dank & Gruss

Rainer
Zitieren




Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste